Well, 2010 MacBook Pro, looks like your days are numbered. Mojave requires 2012+ machines.